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Sage Timeslips Release Notes - May 2021 Release

To download the latest Sage Timeslips Premium Service Release, please refer to Download Sage
Timeslips Premium May 2021 Service Release

To download Sage Timeslips 2020 Perpetual Release, please refer to article ID 96825

Click on any link below to jump to the specific release notes for each version
e March 2020 (Sage Timeslips Premium) Build 29.0.0.42
e June 2020 (Sage Timeslips Premium) Build 29.0.1.64
e October 2020 (Sage Timeslips Premium) Build 29.0.2.92
e January 2021 (Sage Timeslips Premium) Build 29.0.3.96

e May 2021 (Sage Timeslips Premium) Build 30.0.0.18

Service Release for March 2020 (Timeslips Premium) adds the following enhancements:

Enhancement #01: Billing Cycle: Undo Multiple Bills

Details: If you need to change details on a client's bill, in previous versions you were able to undo only
the last approved bill. Now, you may be able to undo multiple bills for that client. Select Bills > Undo
Multiple Bills to open the Undo Multiple Bills dialog box.

e This undo process provides images of any bills you undo. It also includes details such as the slips,
transactions, and billing arrangements included on the original bills to make it easy for you to re-
bill your client.

e Please note that only bills generated after build 29.0.0.000 will be available to undo with this
feature. You can see which build was installed for each bill run on the Review Bill Runs dialog
box (select Bills > Review Bill Runs).

(Ref: 102682)
Enhancement #02: Find and Replace

Details: You can use Find and Replace to search for text within many areas of Timeslips and replace it
with other text. For example, a client may have changed its firm name and you want to quickly change



that name in slip descriptions, payment descriptions, and other areas. To search for text, select Special >
Find and Replace to open the Find and Replace dialog box.

(Ref: 102681)

Service Release for March 2020 (Timeslips Premium) fixes the following problems:

Issue #01: When creating or editing tasks (select Names > Task Info) or expenses (select Names >
Expense Info), you could not type a negative number in the Markup/Discount field. Note: For tasks, this
field is on the Billing page of the Task Information dialog box; for expenses, this field is on the Billing
page of the Expense Information dialog box.

(Ref: 41308)

Issue #02: When viewing Client Information (select Names > Client Info), you can click the Export button
from the toolbar to export values from one client to other clients. Exporting custom field values from
one client to other clients could cause a SQL error.

(Ref: 41316)

Issue #03: You can set up a task (select Names > Task Info) to use a Flat rate when calculating the value
of its slips. Sometimes when you created a new slip (select Slips > Time and Expense Slips) for that task,
the rate type on the slip wasn’t automatically being set to Flat.

(Ref: 41310)

Issue #04: When using LawPay (www.LawPay.com) to accept payments and synchronize them with
Timeslips, credit card payments with names over 45 characters can cause a SQL error.

(Ref: 41313)

Issue #05: You can create Transfer transactions to transfer unapplied payments from one client to
another. When you create a Transfer transaction by clicking Transfer Payment on an existing Payment,
the resulting Transfer transaction will not post to your general ledger (for those customers using TAL or
TAL Pro).

(Ref: 41313)

Issue #06: When printing reports (select Reports > Slips), some user-defined reports were not showing
the subtotals. You can set up subtotals on the Sort and Subtotal page of Report Entry.

(Ref: 41305)

Issue #07: When previewing the pre-bill worksheet (select Bills > Pre-bill Worksheet) on display, if you
click on a Fund Replenishment amount, Client Information may open to the wrong client.

(Ref: 41309)



Issue #08: Statements (select Bills > Generate Statements) may ignore date filters that you set up, so
transactions that you wanted to exclude may show on the statement. Note: You can set up selection
filters on the Selection Filters page of Report Entry.

(Ref: 41307)

Issue #09: When sending bills to your clients by email (select Bills > Generate Bills), pages within the
emailed PDF could be out of order.

(Ref: 41306)

Issue #10: When printing bills, you can set up options to include other items in the bill run, such as
envelopes, a bill summary worksheet, or an invoice listing. If you included a bill summary worksheet,
Timeslips may display an error and close.

(Ref: 41318)

Issue #11: You can use Alerts (select Special > Alerts > Manager) to notify you of data-related events.
Alerts that you set up to notify you of events related to client funds may not trigger properly.

(Ref: 41312)

Issue #12: When hiding features using Features Enabled (select Setup > Features Enabled), the Setup >
Performance Settings command could be mistakenly hidden. Note: The Performance Settings command
is used to quickly disable features that could affect database performance.

(Ref: 41311)

Service Release for June 2020 (Timeslips Premium) adds the following enhancements:

Enhancement #01: Printing PDF Attachments with Bills

Details: When printing attachments with bills, previous versions of Timeslips could only include image-
based attachments. Timeslips can now also include PDF-based attachments.

To access the new option:

o select Bills > Generate Bills

o click the Options button

e optionally mark Print PDF attachments
(Ref: 103322)

Enhancement #02: Maintaining Auto Payments when Undoing Bills



Details: In previous versions of Timeslips, when you undid approval for a bill that included automatic
payments from funds, Timeslips would delete those payments. Now, you can choose how Timeslips
handles that situation.

To access the new option:
e select Setup > General
e switch to the Slips, A/R, & Funds page

e use the Auto Payments options at the bottom of this screen to determine how to handle automatic
payments

(Ref: 103323)
Enhancement #03: Add Audit House details to the Bill Stages dialog box

Details: You can use the Bill Stages dialog box (select Bills > Approve or Clear Bills) to move clients
through the billing cycle. The pages of this dialog now show the audit house (if any) used to export each
bill's data for review.

(Ref: 98561)
Enhancement #04: Specify Format of Quantity field in Audit House Export

Details: When setting up audit house templates (select Setup > Audit Houses), you can now determine
how many decimal places to show for quantity/unit fields.

(Ref: 103358)
Enhancement #05: Adding Last Transaction Date to Funds Account Listing

Details: When printing the Funds Account Listing report (select Reports > Funds Transactions), there is a
new option, Show last transaction date. Use this option to show the date of the last transaction
affecting each of the funds accounts included on the report.

(Ref: 103321)

To access the new option:

e select Reports > Funds Transactions

e double click on the Funds Account Listing
o click Options

e optionally mark Show last transaction date



Enhancement #06: Updating Other Report Fields

Details: On user-defined reports, bills, and statements, you can place database fields on the report
layout and they show values from the database when you print the report. Several fields were showing
blank values when printing the report.

Service Release for June 2020 (Timeslips Premium) fixes the following problems:

Issue #1: When customizing bill layouts (select Bills > Bill and Statement Layouts), you can change the
phrases that appear on bills. If you changed the "Other" phrase, which is used when summarizing slips
by reference, bills do not reflect your changed phrase.

(Ref: 41539)

Issue #2: When sending bills to clients by email, if you approve only part of the bill run (choosing
"Approve some bills from this bill run" on the Generation of Bills Completed dialog box, you may be
prompted twice to select clients and send the approved bills by email.

(Ref: 41540)

Service Release for OCTOBER 2020 (Timeslips Premium) adds the following enhancements:

Enhancement #01: eCenter ClientAccess Administration

Details: Each account in Sage Timeslips eCenter can share account balances and transaction status with
up to 100 of their clients. In past versions, you managed access for your eCenter clients through the
Admin Functions page on Timeslips eCenter. We now offer improved management of Client Access
directly in Sage Timeslips (select Special > eCenter > Manage Client Access). Here you can review all
clients at once and also change access for clients in batches instead of one at a time.

(Ref: 105920)
Enhancement #02: Show eCenter Information in Timeslips Navigators

Details: When your timekeepers enter slips in eCenter, you have to mark those slips Complete and then
transfer them to Timeslips before they can appear on bills. If you forget to do this before billing, your
bills could be incomplete. We now offer an eCenter section for use in Timeslips navigators (select
Special > Navigator) or in Timeslips Today (select Special > Sage Timeslips Today > Show Sage Timeslips
Today). This new section shows the current count of Completed and Not Completed slips in eCenter,
shows when you transferred last, and offers quick access to start the transfer process.

(Ref: 105922)

Enhancement #03: New eCenter fields for User-Defined Client Listings



Details: When designing user-defined client listings (select Reports > Client), there is a new report field
available: eCenter Login. There is also a new selection filter: Client Has eCenter Login. Using both of
these on a report, you can quickly print a listing of client logins currently in use for eCenter’s Client
Access.

(Ref: 105920)
Enhancement #04: New Report: Aged WIP with Contact Info

Details: This new report is available within Client reports (select Reports > Client). It shows work in
process for each client totalled by your custom aging periods. This report also includes phone and email
information for each client in case you need to contact them about their upcoming charges. You can use
the report as-is or customize it further by adding or removing fields in the Report Designer.

(Ref: 105693)
Enhancement #05: New WIP fields for User-Defined Client Listing

Details: When designing user-defined client listings (select Reports > Client), there are several new WIP-
related report fields available. The new Aged WIP group adds over 30 new fields that you can use to
build your own custom Aged WIP reports.

(Ref: 105693)

Service Release for OCTOBER 2020 (Timeslips Premium) fixes the following problems:

Issue #1: Within the Slip Entry dialog box (select Slips > Time and Expense Slips and double click on a
slip), you can click the Export button from the toolbar to export slip fields from the current slip to other
slips. When using this process, the Client field could be listed twice for export.

(Ref: 41964)

Issue #2: On the List View of Billing Assistant (select Bills > Billing Assistant) you were not able to use
right-click commands, which are also available in other parts of Timeslips, to mark and unmark clients.

(Ref: 41965)

Issue #3: You can use the Audit House Setup list (select Setup > Audit Houses) to set up templates for
electronic billing. When creating or editing templates for one of the LEDES styles, the Law Firm ID value
may not save correctly.

(Ref: 42014)

Service Release for JANUARY 2021 (Timeslips Premium) adds the following enhancements:

Enhancement #01: View the Time and Expense List by My Week or My Month



Details: When viewing slips on the Time and Expense Slip List dialog box (select Slips > Time and
Expense Slips), there are new ‘View By’ options that let you quickly see slips for the current week or for
the current month for the logged in timekeeper. From the ‘View By’ field, choose My Week or My
Month. Optionally click Print from the toolbar to include these slips in a Slip Listing report.

(Ref: 109380)
Enhancement #02: Show the Running Balance on the Accounts Receivable List

Details: When viewing transactions on the Accounts Receivable List dialog box (select Transactions >
Accounts Receivable) by client, you can include a Running Balance column so you can see how each
transaction affected the balance.

To view the list in this format, select Transactions > Accounts Receivable to open the list, set ‘View by’
to Client, right click on the list and choose List Appearance Options, and then set Field Themes to
Running Balance.

(Ref: 109381)
Enhancement #03: Include or exclude Proof slips on slip-related reports

Details: When viewing slips on the Time and Expense Slip List dialog box (select Slips > Time and
Expense Slips) or when printing slip-based reports (select Reports > Slips), you can use selection filters
to choose which slips to include.

There is now a Slip Proof selection filter so you can specifically include or exclude slips that are on Proof
Stage.

On the Time and Expense Slip List, click the Selection button to use this selection filter.

When setting up slip-based reports, double-click on the report to open Report Entry and then use the
Selection Filters tab to use this selection filter. This selection filter is available on the following reports:
Slip Listing, Slip Summary Listing, User-Defined Slip Listing, and User-Defined Slip Summary.

(Ref: 103598)
Enhancement #04: Include or exclude all Time or all Expense slips on bill-related reports

Details: When viewing billing information or when printing bill-related reports (select Reports > Billing),
you can use selection filters to choose which slips to include.

There is now a Slip Type selection filter so you can specifically include time slips or expense slips.

When reviewing billing information on the Billing Assistant (select Bills > Billing Assistant) or Firm
Assistant (select Bills > Firm Assistant), click Selection to use this new selection filter.



When setting up bill-related reports, double-click on the report to open Report Entry and then use the
Selection Filters tab to use this selection filter. This selection filter is available on the following reports:
Generate Bills, Pre-bill Worksheet, Totals Only Worksheet, Firm Assistant Listing, and Firm Assistant
Totals.

(Ref: 109382)

Service Release for JANUARY 2021 (Timeslips Premium) fixes the following problems:

Issue #1: Areas that showed Time Spent totals in decimal format could rarely be off by 1/100th (0.01) of
a minute. (This did not affect slip values or billed values on reports or bills, only time values) Affected
areas included pre-bill worksheet, billing assistant, time sheet, day view, and week view.

(Ref: 42414)

Issue #2: When approving bills for clients (select Bills > Approve or Clear Bills), you can automatically
send a copy of the bill by email to clients with an email address assigned. Sending bills by email for a
very large number of clients at once could result in a SQL error.

(Ref: 42415)

Issue #3: In order to purge a client (which removes it completely from Timeslips), you must first close
that client using the Close toolbar button on the Client List (select Names > Client Info). However, if a
closed client had an undoable bill, previous versions of Timeslips may have prevented the purge process.

(Ref: 42416)

Issue #4: When printing the Aged WIP report (select Reports > Client), you can use Report Options (click
the Options button in Report Entry) to choose which fields appear for each client and you can format
the report. In Report Options, if you unmark ‘Show the oldest period first’, report totals may be
incorrect.

(Ref: 42417)

Service Release for MAY 2021 (Timeslips Premium) adds the following enhancements:

Enhancement #01: View the Time and Expense Slip List by My Day.

Details: On the Time and Expense Slip List (select Slips > Time and Expense Slips), set View By to My
Day. The list will show slips for the logged in timekeeper for one day.

(Ref: 110965a)
Enhancement #02: Quick date navigation for My Day, My Week, and My Month.

Details: On the Time and Expense Slip List (select Slips > Time and Expense Slips), when viewing slips by
My Day, My Week, or My Month, you can now quickly move through groups of your slips.



For example, when viewing slips by My Month, you can click the < and > buttons to move through each
month, you can click on the month name to enter another date, or you can click Today to jump back to
the current month.

(Ref: 110965b)
Enhancement #03: Show slip source information on slips and on the slip list.

Details: Timeslips tracks the source of where time and expense slips were created. You’ve been able to
filter or sort Timeslips reports by this information. This is useful in firms that use eCenter, TimeCapture,
or TSImport, if they have to review slips from other sources. This source information can now display
within the Time and Expense Slip List (select Slips > Time and Expense Slips then right click on the list
and choose List Appearance Options). It will also appear within Slip Entry (select Slips > Time and
Expense Slips then open a slip) when the source is something other than Timeslips.

(Ref: 88729)
Enhancement #04: Prevent access and changes to invoice Contributions information

Details: Timeslips shows contributions information on the Contributions tab of invoice transactions
(select Transactions > Accounts Receivable and open an invoice). For invoices that had no associated
slips (for example, billing arrangements with no slips or manually entered invoice transactions) Timeslips
uses the Contributions tab to choose which timekeeper is associated with these charges. Timeslips now
includes new security rights (select Setup > Security > Security Settings, then double click on a
timekeeper, and switch to the Billing tab) to View Timekeeper Contributions and Edit Timekeeper
Contributions.

(Ref: 110988)
Enhancement #05: Approving a payment/credit/writeoff without sending out a bill

Details: If you receive a final payment from a client to close their account, or if you are crediting or
writing off a balance to close their account, you may want to approve the bill without following the
traditional bill process. From the Accounts Receivable List (select Transactions > Accounts Receivable)
or from the Accounts Receivable Entry (open a transaction from the Accounts Receivable List), right click
on the payment, credit, or write-off and choose Approve This Transaction, You cannot use this process
if the client has any other charges, accounts receivable transactions, or client funds transactions.

(Ref: 88727)
Enhancement #06: On the Billing Assistant List, you can show Nickname 1, Nickname 2 or Both.

Details: When viewing the Billing Assistant List (select Bills > Billing Assistant) you can now control
which name will appear for each client. Right click on the list and choose Show Nickname 1, Show
Nickname 2, or Show Both Names. You can also click and drag the sides of the list to adjust the width, if
you need more room to fit names.



(Ref: 110966)
Enhancement #07: You can keep all bill images for specific clients.

Details: You have been able to set how many bill images to save for each client within General Settings
(select Setup > General > Bills). Each saved bill adds to the size of your database, so you may not want to
keep every bill image for every client. Now you set a limit that all clients will follow, while overriding this
setting for specific clients. In the Invoices page of Client Information (select Names > Client and open a
client), you can mark Keep all bill images for clients that you want to ignore the general setting and
keep all bill images.

(Ref: 110987)
Enhancement #08: New selection filter for slips that span multiple days

Details: When reviewing time and expense entries, you may want to focus on slips that span multiple
days to ensure they should span those days. There is now a Slip Spans Multiple Days selection filter that
you can use on the Time and Expense Slip List dialog box (select Slips > Time and Expense Slips) and slip-
based reports (select Reports > Slips).

(Ref: 103603)
Enhancement #09: New fields for user-defined client reports

Details: There are four new fields available for user-defined client listing and user-defined client
summary reports (select Reports > Client). These fields show totals of payment amounts for each client,
excluding payment amounts that originated from client funds. When you are designing a report, they
are available in the Accounts Receivable Totals group. They are: Payments Fees excl Funds, Payments
Costs excl Funds, Payments Interest excl Funds, and Payments Total excl Funds.

(Ref: 111048)
Enhancement #10: Conflict checking can look for additional text

Details: Based on your settings (select Setup > General > Conflict Checking), you can check for conflicts
when you create a new client or timekeeper. You can also check for conflicts at any time within the
Client Information dialog box or the Timekeeper Information dialog box. During these conflict checks,
you can now enter text to search for and Timeslips will search for that text throughout the database,
along with the Nickname 1, Nickname 2, or Full Name for the current client or timekeeper.

(Ref: 111037)
Enhancement #11: Remember TimeCapture password

Details: If you use TimeCapture (select Special > TimeCapture) and you have security set up for
Timeslips (select Setup > Security > Security Settings), you are prompted for a password when you
convert slips from TimeCapture. When prompted, you can now mark Remember password for 15



minutes so if you are converting multiple slips individually, you don’t have to keep entering the
password.

(Ref: 111040)
Enhancement #12: Automatically check for updates

Details: You can now set your preferences (select Setup > Preferences) to have Timeslips check for
updates at startup. On the Startup and Exit page, set the frequency of when Timeslips will check for
Product Updates. When an update is available, you will be notified in the bottom status bar of the
Timeslips window. You can also check for updates at any time using the Help menu (select Help > Sage
Support > Check for updates).

(Ref: 86611)

Service Release for MAY 2021 (Timeslips Premium) fixes the following problems:

Issue #1: In a network installation, you run the “local installer” on any workstation that will use
Timeslips. When running the “local installer” on a new, clean workstation, it will no longer install the
TimeslipsBackup service for scheduled backups.

(Ref: 42709)

Issue #2: After patching a network installation, you will be prompted to update local workstations when
you start Timeslips on those workstations. When updating local workstations in this way, if the
TimeslipsBackup service for scheduled backups was not running on the workstation, then the patch will
not restart it after the patch is applied.

(Ref: 42710)

Issue #3: You can use TSImport (select File > Import) to import data into Timeslips from files created by
other applications. When setting up a TSImport template to import time slip data, accessing the
attributes of the Rate Source field can cause an AV error.

(Ref: 42715)

Issue #4: Editing and saving a Payment from Account (PFA) transaction (select Transactions > Client
Funds), can result in a "corrupted or illegal data” error.

(Ref: 42716)

Issue #5: Editing and saving the description of a Payment from Account (PFA) transaction using the
Client Funds List (select Transactions > Client Funds), does not also update the description in the
associated payment transaction.

(Ref: 42930)



Issue #6: When sorting the user-defined slip summary report (select Reports > Slips) by month and
timekeeper, subtotaled names can incorrectly appear multiple times.

(Ref: 42712)

Issue #7: The BSV - CRE - WRO field on a user-defined slip report doesn’t calculate properly unless other
credit and write-off fields are also included on the report.

(Ref: 42929)

Issue #8: If you set up fee allocation, you can include related fields on the user-defined client listing
report (select Reports > Client). When designing the user-defined client listing, these fields will be
available in the Client Custom group. Percent fields for fee allocation would not show proper values on
the report unless you also included any field from the Client Balances group.

(Ref: 42711)

Issue #9: You can set up audit house templates (select Setup > Audit Houses) to send client billing data
in different electronic formats. When sending data in LEDES1998BI format, if you use taxes then the
LINE_ITEM_TAX_RATE and LINE_ITEM_TAX_TOTAL values can be inflated.

(Ref: 42714)

Issue #10: Using Timeslips Administrator (select Special > Timeslips Administrator), you can set the
timeout due to inactivity for your Timeslips database (click the Database Timeout button at the bottom
of the screen). The longest timeout due to inactivity that you can set now is 2 hours.

(Ref: 107567)

Issue #11: When using Data Verification through Timeslips Administrator (select Special > Timeslips
Administrator) to repair data, you are prompted to back up your database to a file. Backing up to a
single file instead of the server may result in an invalid backup path.

(Ref: 42708)

Issue #12: When linking with a third-party application like Amicus, Timeslips could have a problem
posting entries from that application.

(Ref: 42928)



